Instalación de Flex 2 en Ubuntu

Hace apenas un par de dias que volví a mi viejo y querido Ubuntu. Ya lo extrañaba demasiado!! Así que ni bien quedó instalado empecé a agregarle algunos de los paquetes multimedia, para poder escuchar mi musica y ver Moebius, una pelicula que recomiendo… 🙂

Despues me instalé el Eclipse, el IDE por excelencia para Java.

Hace poco escribí un articulo sobre el minitutorial que encontré en Daniel’s blog sobre la instalacion de Flex 2 en Debian Linux. Ahora es mi turno de explicar como instalar Flex Builder 3 como plugin para Eclipse en Ubuntu 7.04 – Feisty Fawn.

Instalación de Flex 2 como plugin para Eclipse en Ubuntu

Lo primero que debemos hacer es descargarnos la version Europa (3.3) desde la pagina de Eclipse. En la pagina de downloads se encuentra el archivo eclipse-java-europa-fall2-linux-gtk.tar.gz, una vez que lo bajamos, hay que descomprimirlo. En mi caso lo que hice fue crear una carpeta llamada “eclipse” en mi carpeta personal: /home/mato/eclipse.

Siquiente paso, descargar el Flex builder 3 para linux desde la pagina de Adobe. Una vez que lo tenemos, hay que ejecutarlo, para eso accedemos a una terminal y escribimos: $ ./flexbuilder_linux_install_a1_100207.bin

En consola se verá algo asi:

pantallazo-matomato-desktop-descargas.png

Despues de esto se despliega la aplicacion de instalacion de Flex.

pantallazo.png

Despues de la introduccion y la aceptacion de los Terminos y Condiciones, aparecerá una ventana en donde debemos especificar la carpeta de instalacion:

pantallazo-adobe_flex_builder_linux-1.png

Yo elegi instalarlo tambien dentro de mi carpeta local.

Siguiente paso, especificar donde está la carpeta de Eclipse, en mi caso está en /home/mato/eclipse:

pantallazo-adobe_flex_builder_linux-2.png

Lo que sigue es instalar el debugger de flash 9. En ese paso solo debemos presionar “siguiente”. Despues de eso aparecerá una ventana con el resumen de la instalacion:

pantallazo-adobe_flex_builder_linux-4.png

Instalando:

pantallazo-adobe_flex_builder_linux-6.png

y cuando la instalacion termina nos muestra una ventana similar a esta:

pantallazo-adobe_flex_builder_linux-7.png

Ok, ya tenemos instalado el Flex Builder 3 como plugin para Eclipse.

Para poder empezar a crear aplicaciones con Flex 2, lo que hay que hacer es iniciar el Eclipse y seleccionar: File /New /Proyect… y se desplegará una ventana como esta, en donde hay que elegir la opcion Flex Project, dentro de Flex Builder y presionar “next”:

pantallazo-new-project.png

Nos pedirá un nombre para el nuevo proyecto y presionamos”Finish“.

Se puede ver como Flex nos deja listo todas las carpetas que vamos a necesitar para crear nuestras aplicaciones sobre la izquierda de la imagen. Sobre la derecha se ve el AS (ActionScript) que compone a nuestra aplicacion.

Lo que hice aqui solamente fue colocar dentro de la aplicacion “myApp.mxml” un VBox y a este insertarle una etiqueta con un texto.

pantallazo-flex-development-myapp-src-myappmxml-eclipse-platform.png

Para ejecutar nuestra super aplicación lo único que debemos hacer es botón derecho y elegir “Run As Flex Aplication”

pantallazo-flex-development-myapp-src-myappmxml-eclipse-platform-1.png

y esta es la salida que tenemos en el navegador:

pantallazo-5.png

Extremadamente sencillo, no?

Espero que haya servido de algo.

Se agradecen comentarios 🙂

Anuncios

Etiquetas: , , , , , , , , ,

16 comentarios to “Instalación de Flex 2 en Ubuntu”

  1. Matias Lennie Says:

    Mucho, Malganares! Lo instalo, pero voy a necesitar unas charlas con vos que me pongan a punto. Socialice, Malganares! =)

  2. helberth Espindola Says:

    Excelente tutorial. Pero tengo una duda. La instalacion para 64 bits cambia en algo ?

  3. mat0 Says:

    Hola Helberth, muchas gracias. Esta explicacion es para plataformas de 32 bits, pero igualmente creo que no debería cambiar en nada la instalación en arquitecturas de 64 bits. Revisa los requerimientos de sistema en http://labs.adobe.com/technologies/flex/flexbuilder_linux/releasenotes.html. En esa página encontrarás un apartado sobre instalacion en sistemas operativos Linux en 64 bits.
    Saludos

    Mato

  4. Cristian Says:

    Hola, yo instalé eclipse desde los repos, instalé el flex como root para poder acceder a /usr/lib, ahora me funciona el flex únicamente para este usuario, para cualquier otro, no. Podrías ayudarme?. Gracias

  5. mat0 Says:

    Hola Cristian, deberías instalar flex (o cualquier otra aplicación) accediendo como root en /user/share/[aplicacion] para tener acceso desde cualquier usuario.
    Probá con eso y decime como te fué!

    Saludos

    Martin

  6. Cristian Says:

    Si mat0, si me sirvió instalando el flex builder en /usr/share, muchas gracias…

  7. Raziel Says:

    Gracias, Al principio como que no entendia bien como cargar el proyecto pero ahora ya todo listo y funcionando 😉 ya habia trabajado en Win pero no tenia idea del funcionamiento en linux ahora a trabajar se ha dicho. Sigue así.

  8. Fernando Says:

    Hola, estoy trantando de instalar flex pero me arroja el siguiente error me podrían ayudar:
    No Java virtual machine could be found from your PATH
    environment variable. You must install a VM prior to
    running this program.
    Pero tengo instalado todo lo de Java no sé x que me da ese error

  9. Liliana Says:

    Hola Martin,

    Gracias, por tu excelente tutorial. Instale los software sin ningun problema.

  10. mat0 Says:

    @ Fernando: Revisa la configuracion de la Virtual Machine de Java para ver en que ruta esta seteado el Path. La misma ruta debes configurarla en el Eclipse.

    @ Liliana: Me alegro mucho que te haya servido!

    Saludos

    Martin

  11. abc Says:

    El archivo descargado no tiene permisos de ejecución por defecto, en el terminal:

    chmod 777 flexbuilder_linux_install_a1_100207.bin

    Y entonces ya si podemos ejecutar:

    ./flexbuilder_linux_install_a4_081408.bin

  12. David Castillo Says:

    Hola Mat0, disculpa por la pregunta pero a mi tambien me aparece el error de Fernando:

    No Java virtual machine could be found from your PATH
    environment variable. You must install a VM prior to
    running this program.

    Y no se como corregirlo, tienes algún tutorial a la mano??

  13. danervo Says:

    me sale un error en el archivo mxml : Could not open the editor: Assertion failed:

    no me muestra el outline, y el editor no muestra nada,

    gracias por la ayuda

  14. Camilo Says:

    @danervo la sulción es muy sencilla flex solo funciona bajo eclipse 3.3 exactamente, debe descargarte esa versión y reinstalar todo de nuevo y listo!

  15. Camilo Says:

    Cuando trato de hacer un desarrollo en AIR me sale el siguiente error!

    This application requires a version of the Adobe Integrated Runtime (AIR) which is no longer supported. Please contact the application author for an updated version.

  16. Inukaze Says:

    el chmod 777 , es para permitir a cualquiera , Crear/Borrar/Modificar archivos para Usuario , Grupo y Otros

    el chmod o+rw +x “archivo”.”ext” establece que el archivo sera de Lectura + Re-Escritura + Ejecutable

    :=)

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s


A %d blogueros les gusta esto: